ПОЛИАЛФАВИТНЫЕ  ПОДСТАНОВКИ.

Выполнение работы.

1. Запустить на выполнение файл poly.exe.

2. Выбрать в меню пункт Файл -> Открыть.

3. Выбрать в появившемся списке свой вариант.

4. Задайте длину ключа. Для этого вызовите таблицу индекса соответствия. В этой таблице содержатся теоретически ожидаемые значения ИС для различных длин ключа и значение ИС, подсчитанное для конкретной криптограммы. На основании значения ИС выберете длину ключа. Можно использовать два метода:

4.1 Первый метод Фридмана (клавиша F5).

4.2 Второй метод Фридмана (клавиша F6).

5. На основе частотного анализа для каждой группы периода осуществить подстановку (одну). Номер анализируемой буквы ключа (т.е. номер текущей группы периода) указан в заголовке окно статистики. Номер текущей группы периода легко изменить, воспользовавшись клавишами Left  и Right. Существует возможность изменить букву прямо в ключе. Для этого воспользуйтесь клавишей F8.

6. Проанализируйте полученнные текст и ключ. При неудовлетворительном результате измените подстановки в некоторых группах периода. При неудаче изменить длину ключа.

7. Расшифруйте криптограмму, продемонстрируйте преподавателю результат.

Примечание:

Чтобы сохранить результаты свое работы выберите пункт меню Файл -> Сохранить и введите имя файла.


About Chm4You!

О программе Chm4You!
Разработчик: Сергей Тарасенко (aka Tarantul)
Версия: Chm4You! 1.2.1
Веб-сайт: http://supex.by.ru
Почта: tarantuls@ukr.net

Компилятор: hhc.exe 4.78.8702.0 (Microsoft)
Динамическая библиотека: hha.dll 4.78.8702.0 (Microsoft)
Декомпилятор: hh.exe 4.78.8702.0 (Microsoft)