МЕТОД ВЕРОЯТНЫХ СЛОВ

Выполнение работы

1                   Дешифровать криптограмму, зашифрованую шифром Виженера, методом вероятных слов, получить ключ шифрования.

1.1          Запустить на выполнение файл word.exe.

1.2          Выбрать метод простой перестановки, Выбор шифра -> Шифр Виженера.

1.3          Выбрать в меню пункт Файл -> Открыть.

1.4          Выбрать в появившемся списке свой вариант.

1.5          Теперь перед Вами текст криптограммы, меню и строка подсказки. Под строкой криптограммы на экране изображены еще две строки: верхняя строка для ввода и редактирования вероятного слова и нижняя строка для ключа.

1.6          Начните расшифровку с ввода вероятного слова в верхней строке.

1.7          Используются только большие буквы русского алфавита. Буквы “Ъ”, “Ё” и пробел в криптограммах не используются. При вводе можно пользоваться клавишами управления курсором Up, Down, Left и Right, а также клавиши Home, End, Del и BackSpace.
Ввод можно осуществлять в двух режимах: вставки и замены. По умолчанию установлен режим вставки. Переключение между режимами происходит по клавише Ins. Возможен ввод как в строке для вероятного слова, так и в строке ключа. Переключение ввода с одной строки на другую происходит по клавише Tab.

1.8          Подберите перспективную позицию для введенного вероятного слова, пользуясь для сдвига слова влево-вправо клавишами Ctrl-¬ и Ctrl-®. Если в строке ключа появились осмысленные сочетания букв, возможно Вы выбрали правильное вероятное слово. Если во всех позициях получались бессмысленные буквосочетания, попробуйте ввести другое вероятное слово.

1.9          Для ввода короткого ключа воспользуйтесь клавишей F5.

1.10      Постарайтесь “расширить” ключ или вероятное слово. Например, если предполагаемый ключ “..крипто...”, мы можем попробовать расширить его: “криптография”, ”криптоанализ” и т.п. Если в тексте открылось слово “подстановки”, можно попробовать варианты “полиалфавитные подстановки”, “моноалфавитные подстановки”.

1.11      Поочередно расширяя то ключ, то вероятное слово, расшифруйте полностью криптограмму.

Примечание

Чтобы сохранить результаты свое работы выберите пункт меню Файл -> Сохранить и введите имя файла.

2                   Дешифровать криптограмму, зашифрованую “бегущим” ключом, методом вероятных слов, получить “бегущий” ключ.

2.1          Запустить на выполнение файл word.exe.

2.2          Выбрать метод простой перестановки, Выбор шифра -> “бегущий” ключ.

2.3          Выбрать в меню пункт Файл -> Открыть.

2.4          Выбрать в появившемся списке свой вариант.

2.5          Расшифровать криптограмму, действуя согласно пунктам 1.5 – 1.11.

Примечание

Чтобы сохранить результаты свое работы выберите пункт меню Файл -> Сохранить и введите имя файла.

При выборе вероятных слов учесть, что все тексты на тему криптоанализа. Т.е. могут встретиться слова : “частота”, “алфавит”, “подстановки”, “крипто”, “буква”, “метод”, “шифр”, “сообщение”, “информация”, “защита” и т.п.

В криптограммах, зашифрованных “бегущим ключом”, в качестве ключа выбраны строки из известных песен, стихов, а также пословицы.

Если в процессе работы Вы убедились, что ключ периодически повторяется (например, омгромгромгро), можно значительно ускорить расшифровку криптограммы, воспользовавшись функцией ввода “короткого ключа” (клавиша F5).


About Chm4You!

О программе Chm4You!
Разработчик: Сергей Тарасенко (aka Tarantul)
Версия: Chm4You! 1.2.1
Веб-сайт: http://supex.by.ru
Почта: tarantuls@ukr.net

Компилятор: hhc.exe 4.78.8702.0 (Microsoft)
Динамическая библиотека: hha.dll 4.78.8702.0 (Microsoft)
Декомпилятор: hh.exe 4.78.8702.0 (Microsoft)