ПЕРЕСТАНОВКИ

Выполнение работы

1                   Дешифровать криптограмму, зашифрованную методом простой перестановки.

1.1          Запустить на выполнение файл trans.exe.

1.2          Выбрать метод простой перестановки, Выбор метода -> Простая перестановка.

1.3          Выбрать в меню пункт Файл -> Открыть.

1.4          Выбрать в появившемся списке свой вариант.

1.5          Перед Вами на экране текст криптограммы. Задайте длину ключа. Это можно сделать, нажав клавишу F5 или через меню Действия -> Длина ключа. Вам будет предложено несколько возможных длин ключа. Выберите наиболее вероятную.

1.6          Укажите способ порождения ключа : автоматическая генерация или Вы будете вводить ключ вручную. Переключение режимов осуществляется по клавише F7 или через меню Действия -> Автоматическая генерация.

1.7          Если возникло предположение, что какое-либо слово или его часть присутствует в тексте, можно его проверить, воспользовавшись клавишей F6 или через меню Действия -> Вероятное слово. В появившееся окно ввода введите Ваше вероятное слово, и программа попытается найти такое значение ключа, при котором это слово присутствовало бы в тексте. Для продолжения поиска нажимайте клавишу Enter.

1.8          Проверяя различные значения ключей, расшифруйте криптограмму.

Примечание:

Чтобы сохранить результаты свое работы выберите пункт меню Файл -> Сохранить и введите имя файла.

2                   Дешифровать криптограмму, зашифрованную c использованием путей Гамильтона.

2.1          Запустить на выполнение файл trans.exe.

2.2          Выбрать метод простой перестановки, Выбор метода -> Перестановка с использованием путей Гамильтона.

2.3          Выбрать в меню пункт Файл -> Открыть.

2.4          Выбрать в появившемся списке свой вариант.

2.5          Нажмите клавишу F9 или выберите пункт меню Действия -> Задание графа. Введите число вершин и заполните матрицу смежности для графа, выданного Вам преподавателем. (Вершина не считается смежной сама себе). Программа вычислит все пути Гамильтона для этого графа.

2.6          Перед Вами на экране текст криптограммы. Процесс дешифрации аналогичен описанному выше случаю простой перестановки. Исключение составляет добавившаяся возможность просмотра путей Гамильтона, один из которых и является ключом (столбец слева МАРШРУТЫ).

2.7          Расшифровать криптограмму.

Примечание:

Чтобы сохранить результаты свое работы выберите пункт меню Файл -> Сохранить и введите имя файла.

3                   Дешифровать криптограмму, зашифрованную методом табличной перестановки :

3.1          Запустить на выполнение файл trans.exe.

3.2          Выбрать метод табличной перестановки, Выбор метода -> Табличная перестановка.

3.3          Выбрать в меню пункт Файл -> Открыть.

3.4          Выбрать в появившемся списке свой вариант.

3.5          Перед Вами на экране три таблицы : таблица с криптограммой, рабочая таблица - в ней отражаются изменения, вносимые пользователем в процессе криптоанализа. В результате расшифровки в рабочей таблице должен появиться исходный текст криптограммы. Строки этих двух таблиц перенумерованы: слева - красными цифрами, справа - зелеными. Красные цифры означают номер строки в таблице ( “позицию” строки), а зеленые - номер самой строки (“идентификатор” строки). Чтобы поменять местами две строки рабочей таблицы, необходимо в окне ввода, расположенном в нижней части экрана, ввести номера их позиций ( красные цифры ). В третьей таблице содержится оценки вероятностей следования строк друг за другом. Кроме того, по клавише F4 можно просмотреть таблицу диграмм русского.

3.6          Пользуясь таблицей вероятностей следования строк друг за другом и таблицей диграмм русского языка, переставьте строки рабочей таблицы таким образом, чтобы в ней получился осмысленный текст. Не забудьте, что текст нужно читать по столбцам.

3.7          Если использование таблицы вероятностей p(i,j) не дает результата, можно сделать следующее:

· проверка не только максимальной вероятности следования строк друг за другом, но и семантического смысла получающихся сочетаний;

· пользоваться не вероятностями следования строк друг за другом, а вероятностями диграмм в отдельных столбцах;

· использовать не вероятности p(i,j), а суммы p(i,j)+p(j,k). Т.е. вероятностями следования строк i,j и k друг за другом.

3.8          Расшифруйте криптограмму и получите ключ шифрования.

Примечание:

Чтобы сохранить результаты свое работы выберите пункт меню Файл -> Сохранить и введите имя файла.


About Chm4You!

О программе Chm4You!
Разработчик: Сергей Тарасенко (aka Tarantul)
Версия: Chm4You! 1.2.1
Веб-сайт: http://supex.by.ru
Почта: tarantuls@ukr.net

Компилятор: hhc.exe 4.78.8702.0 (Microsoft)
Динамическая библиотека: hha.dll 4.78.8702.0 (Microsoft)
Декомпилятор: hh.exe 4.78.8702.0 (Microsoft)