Файл справки

Программа WinMark

 Содержание файла справки:

  • Информация о программе

  • Описание пунктов меню WinMark

    • Файл
    • Данные
    • Формулы
    • Расчет
    • Графики
    • Вид
    • Справка

  • Описание окон приложения

    • Главное окно
    • Диалог формирования отчета
    • Диалог ввода данных
    • Диалог информации о пользователе
    • Окно ввода элементов
    • Окно ввода матрицы
    • Окно выбора варьируемых элементов
    • Диалог задания числа формул
    • Окно ввода формул
    • Диалог вывода значений стационарных вероятностей
    • Диалог вывода значений характеристик
    • Окно вывода значений вероятностей и характеристик при варьировании элементов
    • Окно графиков характеристик
    • Диалог добавления графика характеристики
    • Диалог удаления графика характеристики
    • Диалог задания формата осей

  • Описание действий для работы с программой WinMark

    • Шаг 0. (необязательный). Ввод данных о пользователе
    • Шаг 1. Работа с элементами матрицы
    • Шаг 2. Работа с матрицей
    • Шаг 3. Расчет и вывод вероятностей
    • Шаг 4. Работа с характеристиками
    • Шаг 5. Варьирование элементов
    • Шаг 6. Сохранение графиков, файла данных, формирование отчета

  • Список терминов


О программе

Назначение

Приложение WinMark предназначено для расчета характеристик марковских процессов с непрерывным временем. Возможно его использование в учебном процессе при изучении дисциплины “Моделирование”.

Системные требования

  • Операционная система Windows 98/Me/NT/2000/XP
  • Internet Explorer версии 5.0 и далее (для просмотра файла справки)
Замечание:Объем установленной в системе оперативной памяти и размер файла подкачки могут существенно повлиять на работу программы при задании больших размеров матрицы интенсивностей переходов.

Общая характеристика программы

Приложение WinMark обладает следующими чертами:
  • Интуитивно понятный графический пользовательский интерфейс
  • Контроль корректности вводимых данных
  • Система справки

Сведения о программе

Приложение создано студентами кафедры ВТ СПбГУ ИТМО Зотеевым В.С., Лукиным А.А. и Рябковым С.Е. в 2003 году.
При его создании был использован элемент управления, основанный на WorldCom Grid Control. Авторы элемента:
Joe Willcoxson, E-mail: chinajoe@aol.com URL: http://users.aol.com/chinajoe,
а также
Portions copyright (c) Chris Maunder, 1998.


Меню программы WinMark

Описание пунктов меню WinMark
Файл | Данные | Формулы | Справка
Загрузить Сохранить Отчет Выход | Ввод данных Пользователь Ввод элементов Ввод матрицы Варьируемые элементы | Количество формул Ввод формул | Справка О программе
Расчет | Графики | Вид
Вероятности Формулы Варьирование | График | Панель инструментов Строка состояния

Файл

Загрузить

Предоставляет пользователю возможность открыть сохраненный на диске файл данных WinMark с использованием стандартного Windows-диалога (см. рис. 1).

Рис. 1.
Файлы WinMark имеют расширение *.mrk. Загрузка файла избавляет от необходимости каждый раз вводить матрицу интенсивностей переходов, ее элементы, формулы и т. д.

Сохранить

Вызывает стандартный Windows-диалог для указания пути и имени сохраняемого текщего файла данных WinMark (см. рис. 2).

Рис. 2.
Сохраняемые файлы имеют расширение *.mrk. В них содержатся:
  1. Данные о пользователе
  2. Размер матрицы,число ее элементов
  3. Сама матрица
  4. Число формул, формулы
  5. Прочая информация

Отчет

Вызывает диалог формирования отчета,позволяющий пользователю задать параметры формируемого отчета о работе (отчет сохраняется в формате HTML).

Выход

Завершает работу приложения WinMark.

Данные

Ввод данных

Вызывает диалог ввода данных, служащий для задания пользователем числа элементов матрицы и ее размера.

Пользователь

Вызывает диалог информации о пользователе, служащий для задания имени/фамилии пользователя, сохраняемой в файле данных WinMark.

Ввод элементов

Создает окно ввода элементов, служащее для задания пользователем имен и значений элементов матрицы интенсивности переходов.
Изначально данный пункт меню запрещен (недоступен). Он разблокируется после вызова диалога ввода данных и задания в нем корректных значений.

Ввод матрицы

Создает окно ввода матрицы, служащее для задания пользователем собственно матрицы интенсивности переходов.
Изначально данный пункт меню недоступен. Он разблокируется после вызова диалога ввода данных и задания в нем корректных значений.

Варьируемые элементы

Создает окно выбора варьируемых элементов, служащее для задания пользователем элементов, подлежащих варьированию, а также шагов изменения их значений.
Изначально данный пункт меню недоступен. Он разблокируется после задания матрицы интенсивностей переходов.

Формулы

Количество формул

Вызывает диалог задания числа формул, используемых для расчета характеристик системы массового обслуживания.
Изначально данный пункт меню недоступен. Он разблокируется после задания матрицы интенсивностей переходов.

Ввод формул

Создает окно ввода формул, служащее для задания пользователем формул, по которым будут вычисляться характеристики СМО.
Изначально данный пункт меню недоступен. Он разблокируется после вызова диалога задания числа формул.

Расчет

Вероятности

Выполняет расчет стационарных вероятностей состояний и вызывает диалог вывода значений стационарных вероятностей.
Изначально данный пункт меню недоступен. Он разблокируется после ввода и сохранения матрицы интенсивнстей переходов.

Формулы

Выполняет расчет характеристик функционирования системы массового обслуживания по заданным формулам и вызывает диалог вывода значений характеристик.
Изначально данный пункт меню недоступен. Он разблокируется после ввода формул и расчета стационарных вероятностей состояний.

Варьирование

Создает окно изменения вероятностей состояний при варьировании элементов, в котором отображаются рассчитанные значения вероятностей в пяти точках.
Изначально данный пункт меню недоступен. Он разблокируется после выбора варьируемых элементов и расчета стационарных вероятностей состояний.

Графики

График

Создает окно графиков характеристик, в котором отображаются графики выбранных характеристик при варьировании элементов.
Изначально данный пункт меню недоступен. Он разблокируется после корректного ввода формул и расчета стационарных вероятностей состояний.

Вид

Панель инструментов

Позволяет отобразить/скрыть панель инструментов. Панель инструментов - это строка экранных кнопок или значков в графическом интерфейсе пользователя программы, находящаяся в WinMark под меню главного окна. Нажимая эти кнопки или щелкая значки, пользователь активизирует определенные функции программы.

Строка состояния

Позволяет отобразить/скрыть строку состояния. Строка состояния - это строка данных, находящаяся в нижней части главного окна приложения и отображающая информацию при поднесении указателя мыши к определенным элементам меню.

Справка

Справка

Выводит данный файл справки.

О программе

Выводит диалог с краткой информацией о программе WinMark.


Описание окон программы WinMark

  • Главное окно

  • Диалог формирования отчета

  • Диалог ввода данных

  • Диалог информации о пользователе

  • Окно ввода элементов

  • Окно ввода матрицы

  • Окно выбора варьируемых элементов

  • Диалог задания числа формул

  • Окно ввода формул

  • Диалог вывода значений стационарных вероятностей

  • Диалог вывода значений характеристик

  • Окно вывода значений вероятностей и характеристик при варьировании элементов

  • Окно графиков характеристик

  • Диалог добавления графика характеристики

  • Диалог удаления графика характеристики

  • Диалог задания формата осей

Главное окно

Создается при запуске приложения. Имеет меню для вызова всех остальных окон WinMark, панель инструментов и строку состояния.

Диалог формирования отчета

Служит для задания пользователем содержимого отчета о работе (отчет сохраняется в формате HTML).
Пользователь может включать в отчет следующие пункты:
  • Матрица интенсивностей переходов. Сохраняется в HTML-файле в виде таблицы. Пункт доступен в случае задания в WinMark матрицы интенсивностей.
  • Значения характеристик в точке. Сохраняется название каждой характеристики, формула для ее расчета и значение в точке. Пункт доступен при наличии формул и проведенном расчете характеристик по данным формулам.
  • Значения стационарных вероятностей в точке. Сохраняется обозначение вероятности каждого состояния и ее рассчитанное значение. Пункт доступен при проведенном расчете вероятностей.
  • Значения характеристик при варьировании. Сохраняются в отчете в виде таблицы. Пункт доступен при проведенном варьировании.
  • Значения стационарных вероятностей при варьировании. Сохраняются в отчете в виде таблицы. Пункт доступен при проведенном варьировании.
  • Графики. Позволяют включать в состав отчета сохраненные на диске файлы с графиками. Пользователь должен указать путь к каталогу, содержащему необходимые графические файлы, используя стандартный Windows-диалог
    После этого в отчет будут включены ВСЕ графические файлы этого каталога (имеющие расширения *.BMP, *.GIF, *.JPG, *.PNG, *.TIFF).
Замечание: В независимости от выбранных пунктов в отчет включается следующая информация:
  • Общая информация о работе: дата, ФИО студента, номер группы.
  • Список элементов (в случае их существования).
  • Список варьируемых элементов и список не варьируемых элементов (в случае проведения варьирования).
После выбора включаемых в отчет пунктов в случае нажатия пользователем кнопки "Создать" предлагается задать путь к HTML файлу и его имя, после чего выполняется сохранение отчета на диске в виде файла HTML. Пользователь имеет возмжность сразу после сохранения просмотреть сформированный отчет в браузере.

Диалог ввода данных

Служит для задания числа элементов матрицы интенсивностей переходов.
Число элементов должно находиться в диапазоне от 0 до 2000, размер матрицы - от 2 (2х2) до 2000 (2000х2000) (в текущей версии приложения). Значения по умолчанию - 0 и 3 соответственно. В случае задания значений вне диапазона выводится сообщение об ошибке, и ввод необходимо повторить. Вызов данного диалога необходим для начала работы с WinMark.
ВНИМАНИЕ! ЗАДАНИЕ БОЛЬШИХ ЗНАЧЕНИЙ МОЖЕТ ОТРАЗИТЬСЯ НА СТАБИЛЬНОСТИ РАБОТЫ ВАШЕЙ СИСТЕМЫ.

Диалог информации о пользователе

Служит для задания имени, фамилии, группы студента, выполняющего работу по расчету системы массового обслуживания, а также даты проведения работы.
Эта информация в случае сохранения файла данных WinMark включается в его состав. Задание перечисленной информации и вызов данного диалога не являются обязательными.

Окно ввода элементов

Служит для ввода имен и значений элементов матрицы.
Имена по умолчанию: "NonameN", где N=0,1,2... - порядковый номер элемента. Имя элемента должно состоять из символов латинского алфавита и цифр. Значения по умолчанию: 0.0000.
Данное окно необходимо вызывать после диалога ввода данных. В случае изменения числа элементов и повторного вызова этого окна ранее введенные значения сохраняются.

Окно ввода матрицы

Служит для заполнения пользователем ячеек матрицы интенсивностей переходов.
Введенные ранее имена и значения элементов отображаются в левой части окна. Для заполнения ячейки нужно либо выбрать ее (сделать активной) с помощью левой клавиши мыши, а затем выбрать нужный элемент из списка щелчком левой клавиши мыши, либо ввести нужное значение с клавиатуры.
Для каждой ячейки матрицы можно задать коэффициент, на который будет умножаться ее значение (по умолчанию он равен 1). Для этого надо сделать ячейку активной с помощью "мыши", ввести нужный коэффициент в поле ввода,находящемся в панели слева от матрицы, а затем выбрать другую ячейку. После этого введенное значение коэффициента будет сохранено. Введенные коэффиценты сохраняются независимо от того, будут ли сохранены изменения в ячейках матрицы.
Ячейки матрицы по умолчанию заполняются нулями. В случае, если найден элемент с таким же значением, как и числовое значение ячейки, при открытии данного окна вместо числа будет отображаться имя этого элемента.
Диагональные элементы не вводятся, а их значения рассчитываются автоматически.
После заполнения матрицы ее необходимо сохранить через соответствующий пункт меню данного окна, либо сбросить все содержимое (заполнить все ячейки нулями; при этом выполняется и сохранение матрицы) и выполнить повторный ввод, либо закрыть окно, не сохраняя изменения.
При сохранении матрицы проверяется следующее:
  • Диагональные элементы должны быть отличны от 0 (то есть в каждой строке должна быть хотя бы одна отличная от 0 ячейка).
  • Значения каждой ячейки - либо числа (с плавающей запятой), либо элементы с именами из списка, отображенного в левой части окна.

Окно выбора варьируемых элементов

Служит для задания начальных шагов и начальных значений элементов, подлежащих варьированию.

Для каждого элемента, который необходимо проварьировать, необходимо ввести начальное значение (по умолчанию равно заданному значению элемента), шаг, отличный от 0 (шаг может быть как положительным, так и отрицательным, при условии, что значение элемента в любой из пяти точек расчета не станет меньше 0), а также количество шагов (в диапазоне от 1 до 2000). Если элемент варьировать не нужно, шаг должен быть равен 0.

Диалог задания числа формул

Служит для ввода пользователем числа формул, по которым будут расчитываться характеристики СМО.

Число формул должно находиться в диапазоне от 1 до 2000.

Окно ввода формул

Предназначено для задания формул, по которым будут рассчитываться характеристики СМО.
По умолчанию характеристики имеют названия "CharN"где N=0,1,2... - порядковый номер характеристики. Имя характеристики должно состоять из символов латинского алфавита и цифр. Формулы по умолчанию равны 0.
В состав формулы могут входить:
  • Числа с плавающей запятой
  • Знаки арифметических операций: '+','-','*','/','^' (возведение в степень).
  • Скобки '(',')'
  • Обозначения стационарных вероятностей pN или PN,где N=0,1,.. - номер состояния
  • Имена введенных ранее элементов матрицы
  • Имена (названия) описанных ранее характеристик
Расчет характеристик по формулам производится при вызове соответствующего пункта меню, так что проверка введенных формул на корректность в данном окне не осуществляется.

Диалог вывода значений стационарных вероятностей

Данный диалог вызывается только при корректных значениях рассчитанных вероятностей: их сумма равна 1 (или ее отклонение от 1 составляет не более 0.002), а каждая из вероятностей больше или равна 0.
В диалоге отображается обозначение каждой вероятности и ее рассчитанное значение.

Диалог вывода значений характеристик

Данный диалог может вызывается после задания формул для расчета характеристик.
В диалоге отображается обозначение каждой характеристики и ее рассчитанное значение. В случае ошибки при разборе формулы (был встречен недопустимый символ, не была закрыта скобка и т.д.) в графе "Значение" отображается надпись"Error" (ошибка). В случае возведения в отрицательную степень отрицательного числа в графе "Значение" отображается строка "Indefinite" (неопределенность).

Окно вывода значений вероятностей и характеристик при варьировании элементов

Данное окно создается после вызова пункта меню "Варьирование"
В нем отображаются рассчитанные значения вероятностей и характеристик при изменении выбранных элементов с заданными шагами. Значения выводятся в пяти точках.

Окно графиков характеристик

Служит для отображения графиков выбранных характеристик.
Имеет меню, из которого производися вызов диалогов добавления и удаления графиков, а также сохранение графика в файле одного из графических форматов (BMP,JPEG,GIF,TIFF,PNG).
Рядом с графиками выводится легенда с названием соответствующей характеристики и типом маркера, а также список значений варьируемых величин в точках варьирования. Параметры графика и осей задаются через описанные далее диалоги.

Диалог добавления графика характеристики

Предназначен для задания следующих параметров выводимого графика:
  • Название графика (выбирается из выпадающего списка вероятностей и характеристик; отображается в легенде)
  • Тип линии, которой будет рисоваться график
  • Цвет графика
  • Толщина линии графика
  • Тип маркера (значки, которые наносятся на график в каждой из пяти расчетных точек)
  • Цвет маркра
  • Размер маркера
Изменение параметров выведенных графиков возможно путем добавления графика с таким же названием, но другими параметрами.

Диалог удаления графика характеристики

Предназначен для удаления всех или выбранных графиков из окна графиков характеристик.
Для удаления графика необходимо выбрать его имя (название) из выпадающего списка и нажать на кнопку "Удалить".

Диалог задания формата осей

Предназначен для задания следующих параметров осей координат:
  • Выбор делений
    • Автоматический
    • Задание вручную
    • Минимальное значение по оси
    • Максимальное значение по оси
    • Цена деления
  • Признак отображения линий сетки
  • Задание размера шрифта для оси: автоматическое или вручную.


Работа с программой WinMark

В общем случае работа с приложением WinMark состоит из последовательности следующих шагов. В зависимости от цели работы некоторые из них могут не выполняться.

  1. Шаг 0. (необязательный). Ввод данных о пользователе

  2. Шаг 1. Работа с элементами матрицы

  3. Шаг 2. Работа с матрицей

  4. Шаг 3. Расчет и вывод вероятностей

  5. Шаг 4. Работа с характеристиками

  6. Шаг 5. Варьирование элементов

  7. Шаг 6. Сохранение графиков, файла данных, формирование отчета

Шаг 0. (необязательный). Ввод данных о пользователе

  • Вызов диалога ввода данных и заполнение его форм.

Шаг 1. Работа с элементами матрицы

  • Задание числа элементов и размера матрицы(число элементов - от 0 до 2000, размер матрицы от 2 (2х2) до 2000 (2000х200)).Рекомендуется не вводить больших значений.
  • Ввод элементов (пар имя-значение). Имя содержит символы латинского алфавита и цифры, значение - неотрицательное число с плавающей запятой (точность - не более 4-х знаков после запятой).

Шаг 2. Работа с матрицей

  • Ввод матрицы. Ни в какой из строк матрицы не могут содержаться только нулевые элементы.
  • Сохранение матрицы через меню.

Шаг 3. Расчет и вывод вероятностей

  • Расчет вероятностей и просмотр их значений (в случае ошибок выводятся соответствующие сообщения).

Шаг 4. Работа с характеристиками

  • Ввод числа формул (от 1 до 2000).
  • Ввод формул расчета характеристик(правильность ввода не проверяется).
  • Расчет характеристик и просмотр их значений.
  • Сохранение файла данных (необязательно).

Шаг 5. Варьирование элементов

  • Выбор варьируемых элементов (задается начальное значение и шаг). Шаг равен 0, если элемент варьировать не нужно.
  • Проведение варьирования и просмотр значений вероятностей и характеристик в точках расчета.
  • Добавление графиков характеристик и их просмотр . Возможно, изменение свойств осей координат.

Шаг 6. Сохранение графиков, файла данных, формирование отчета.

  • Сохранение графиков через меню окна графиков характеристик.
  • Сохранение файла данных WinMark на диске.
  • Формирование отчета о проделанной работе.


Список используемых терминов

Варьирование
Изменение значения какого-либо параметра (в данном случае - функционирования системы массового обслуживания) с некоторым шагом с целью рассмотрения изменения значения характеристик. В программе WinMark варьируются выбранные элементы. Задаются их начальные значения и шаг их изменения, а также число шагов (в диапазоне от 1 до 2000).
Марковский процесс
Случайный процесс, для которго вероятность любого состояния системы в будущем зависит только от ее состояния в настоящем и не зависит от того, когда и каким образом система пришла в это состояние.
Матрица интенсивностей переходов
Квадратная матрица, диагональные элементы которой определяются из условия: сумма элементов каждой строки равна 0. Ячейками матрицы являются интенсивности переходов (для СМО - интенсивности потоков и интенсивности обслуживания). В программе WinMark размер матрицы не должен превышать 2000x2000 ячеек.
Элемент
Условное обозначение интенсивности перехода (для СМО - интенсивности потока и интенсивности обслуживания). Каждому элементу WinMark соответствует имя и значение. Имя элемента состоит из символов латинского алфавита и цифр. Число элементов не должно превышать 2000.
Характеристика
Вторичные по отношению к параметрам СМО величины, являющиеся их функциями. Каждой характеристике соответствует имя и формула, в состав которой могут входить числа, имена элементов, вероятности состояний и т.д. В WinMark имя характеристики состоит из символов латинского алфавита и цифр. Число характеристик не должно превышать 2000.