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1 Introduction 

This document defines the guidelines for creating themes for the Nokia 7710 Widescreen Smartphone and describes 
how to use the features provided by the Nokia 7710 Theme Studio for Symbian OS (hereafter referred to as Theme 
Studio). 

For installation details refer to the Theme Studio installation guide [1]. 

1.1 Themes 

Themes can be used to change the look of a mobile device user interface (UI). For example, themes allow you to 
customize: 

• Application icons 

• Color schemes 

• Logical Fonts and Colors 

Additionally, themes may contain items specific to individual applications, such as the icon used to represent a certain 
application on the mobile device UI. 

A single theme package contains graphics for many changeable components. If a theme package does not contain a 
component, the default UI graphics are displayed. 

Changing a theme affects only the look and feel of the UI. The functions or features of the device are not changed. 
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2 Theme Creation Tasks  
 

This chapter describes how to perform specific tasks with Theme Studio. Each of the following sections describes the 
steps necessary for a specific task. 

2.1 Launching the Application 

Using the Windows Start Menu, go to All Programs> Nokia Developer Tools>Nokia 7710 Theme Studio> Nokia 

7710 Theme Studio 

If you have not already chosen a graphical editor, the following dialog is displayed. 

 

 

Figure 2-1 Browse for Graphical Editor Dialog 

 

To choose a graphical editor, browse to the location of your chosen editor application, select the associated application 

icon, and click Open. To bypass selection of a graphical editor at this time, simply click the Cancel button. In either 
case the Theme Studio application will continue launching.  

Note: To edit images, a graphical editor must be selected. To do so, always click Tools >>>> Set Graphical Editor.  
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2.2 Setting the Graphical File Format Priority 

Graphical file format priorities are used by Theme Studio to determine which Layout Files image format it should use. 

To set the graphical file format priorities, on the Tools menu, click Set the Graphics File Format Priorities. The 
following Graphic File Format Priority Dialog is be displayed. 

 

 

Figure 2-2 Graphics File Format Priority Dialog 

When creating a new project, the default Layout Files generated by Theme Studio are created in the highest priority 
format, so this format should match the format used by the preferred graphical editor. For example, if the graphical editor 
to be used is Adobe Photoshop then this format should be at a higher priority than the Bitmap format as shown in Figure 
2-2. The Bitmap format shall always be supported and therefore cannot be removed from the priority list. 

The priorities are also used in the case where Layout Files may exist in multiple image formats, to determine the order in 
which Theme Studio imports those Layout Files. For example, if the Layout Files was initially generated in Bitmap 
format, but later some are converted to Adobe Photoshop format, then Adobe Photoshop format must be of higher 
priority than Bitmap format in order for the Adobe Photoshop files to be used. 

 

2.3 Working with a Theme Project 

When Theme Studio is started the Welcome dialog (see Figure 2-3) is presented. This allows you to select a theme 
project to work with. 
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Figure 2-3 Theme Studio Welcome Dialog 

2.3.1 Creating a new theme project 

To create an entirely new theme project, perform the following steps: 

1. Select Create a new project, and click the OK button. A dialog box will be displayed similar to the one in Figure 
2-4.  

 This dialog box provides a list of Theme Templates and is used to select the type of theme upon which the new 
project is to be based. 

Note: Note: Note: Note: To create a new project,always click New on the File menu,. 

 

Figure 2-4 Theme Template Selection Dialog Box 

2. Select the Main Theme option from the list. 

 The new theme will be based on the theme provided as default with the Nokia 7710 smartphone, allowing the 
theme designer to make changes without having to produce an entirely new theme. 

 Click the OK button, a browse dialog is displayed. This dialog is used to select or create the folder for the new 
project. 
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Figure 2-5 Browse Dialog Box 

3. Browse to the folder that will contain the new project’s folder, and click Make new Folder.  

 You can cancel theme creation by clicking Cancel. 

4. Name the folder for the new project, and click the OK button. The Theme Project will be created, and the application 
will open the project (Figure 2-6). The name of the new theme is displayed at the root of the tree view in the left 
hand pane. 
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Figure 2-6 Example Project 

2.3.2 Opening an existing theme project 

To browse to an existing project perform the following steps: 

1. Select Open an existing project, followed by Choose Project, then click OK. 

2. A “Browse For Folder” dialog is now displayed. This dialog is used to select the folder that contains the project to be 

opened. Browse to the project folder that is to be opened and click OK.  

 

To open a recently used project select Open an existing project, pick the project name from the list, and click OK. 

 

The following outcomes may occur: 

a. If a folder is chosen that contains no Theme Project File, a dialog displays an error. Clicking the OK button 
dismisses the dialog. 

b. If there is a problem with the Theme Project File, a dialog will be displayed stating that there was an error 

loading the selected project. Clicking the OK button dismisses the error dialog.  

c. If the chosen folder contains a valid theme project, Theme Studio will open it. The name of the project is 
displayed as the root of the tree view. 

Note:  To open an existing project, always click on the File menu, click Open or click Project name, where “Project 
name” is the desired project. 

2.4 Saving a Project in a New Location 

When a project is open, you can save the project to a new location using the following steps: 
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1. On the File menu, click Save As. 

2. A “Browse for Folder” dialog is displayed. This dialog is used to select or create the subfolder for the new project 
(this folder should be empty). Browse to the folder that will contain the folder for the new project. If the folder does 

not already exist, click the New Folder button.  

3. Name the folder for the new location, and click the OK button. The project is now saved to the new location and the 
name of the project displayed at the top of the tree view will have changed to the name of the new folder. 

2.5 Browsing the Tree 

The left hand pane contains a tree view, which is the main method of selecting areas of a theme to be edited. The tree 
contains all the components that make up a theme, along with the general settings such as logical fonts and global 
properties. 

Clicking the Expand All button opens the entire contents of the tree view. Clicking the Collapse All button closes the 
entire contents of the tree view, except for the currently-selected tree item. 

Individual tree items can be explored using the expand node (+) and collapse node (-) controls on the tree view. 

You can also expand and collapse a given tree item by right-clicking on the item. You can also mark complete / 
incomplete individual tree items or whole categories as can be seen in Figure 2-7. 

 

Note: The option to mark a tree item as complete is not available if the item contains validation failures. 

 

                

Figure 2-7 Browsing the Tree 
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2.6 Components 

The Components category contains the visible components for a theme, for example, buttons, dialogs, and icons. 
 

 

Figure 2-8 Component view 

When a component is selected in the tree view, two main views are displayed to the right of the tree, as in Figure 2-8. 
The top view displays the preview image of the component. The bottom view is used to display five different types of 
information relevant to the component. These are: 

• General Info, which contains useful information about the component 

• Configure, which contains configurable data, such as margin widths 

• Comments, which contains useful footnotes created by a user, such as reminders 

• View Layout, which displays the layout image in the Layout File 

• Errors, which displays a list of validation failures specific to the component 

A view is selected from the row of “view change” buttons.  

2.6.1 Preview area 

The preview area shows an illustration of how the selected component will appear on the device. The image is 
generated from the Theme Layout Files and may be based upon multiple image elements from those files. 

Moving the mouse over an individual image element will show a tool tip, indicating the Layout File and position within 
that file from where the element comes (See Figure 2-9). This is useful when the image must be edited. 
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Figure 2-9 Preview area with a tool tip showing image element properties 

Some components will have text positioned over them when on the device. To simulate this effect in the preview area, 

check the View fonts box. 

Moving the mouse over an area of text will show a tool tip, indicating the logical font and color being used to display the 
text (See Figure 2-10). 
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Figure 2-10 Preview area with text properties 

If a component is interactive when on the device, in the way buttons are, the preview area will also have an interactive 
element that can simulate the effect of user interaction on the component. 

Figure 2-11 shows the preview area for the Call Header Buttons. At the bottom of the preview area is an interactive 

preview of this component, which when hovered over with the mouse displays the tool tip Click here to test. 
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Figure 2-11 Preview of interactive component 

Left-clicking with the mouse on this area will change the preview to show how this component will look when it is clicked 
on the device (See Figure 2-12). 
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Figure 2-12 Preview of interactive component when left-clicked 

For animated components, such as the progress animations, the preview area also has an animation element that can 
simulate the display of the animation. 

Figure 2-13 shows the preview area for the Process progress animation. At the bottom of the preview area is a 
simulation of how the animation will appear on the device. 

Moving the mouse over the animation will show the tool tip Click here to stop animation. Left-clicking with the mouse 
will cause the animation to pause. 
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Figure 2-13 Preview of animated component  

2.6.2 Layout File area 

The Layout File area appears when the View Layout tab is selected from the central pane and shows how the Layout 
Files used to generate this component have changed from the versions generated when the project was created. This is 
useful when checking the boundaries of component elements. 

The initial Layout File can be seen when the View graphics over layout tick box is not ticked, or the edited graphics 

can be superimposed over the initial graphics by selecting the View graphics over layout tick box. This can be seen in 
Figure 2-14 and Figure 2-15 respectively. 
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Figure 2-14 Layout File area 
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Figure 2-15 Layout File area with the edited graphics superimposed 

2.6.3 Configuring a component 

Some components have configurable properties that can be viewed and altered by selecting the Configure tab. These 
changes will affect the preview images of these components.  

The following example illustrates the steps and actual results of changing the configurable properties for the Call Header 
Buttons component of the project created in Section 2.3.1, ”Creating a new theme project”.  

1. On the left hand tree view, expand Theme Project, then Components, then Buttons, and click Call Header. 

2. Select the Configure tab from the central pane. 

3. This particular component uses fonts. In the preview screen tick the View fonts check box. The configurable 
properties affect the positioning of the font. The application will now display the components[b1] displayed in Figure 
2-16 below. 
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Figure 2-16 Call Header Buttons before changing Configurable Properties 

 The preview image in this case displays in descending order the normal, pressed, and disabled composite images 
for the call header buttons and an interactive preview.  

4. In the bottom pane, change the value in the edit box for the “Middle button, Left margin” from 15 to 1. 

 On the View menu, click Refresh (keyboard shortcut F5), which will update the Preview area showing that the text 
has moved for the composite pressed buttons (as can be seen in Figure 2-17). To test how the button behaves 
when pressed, left-clicking down while over the button. 
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Figure 2-17 Call Header preview following a change to the button property “Middle button, Left margin” 

 

The previous example shows how the text for a Component can be moved around using the Configure tab. 

The following example illustrates the movement of image parts by changing the configurable properties for the 
Horizontal Seek Bar Component.  

1. On the left hand tree view, expand Theme Project, then Components, then Seek Bars, and click Horizontal. 

2. Select the Configure tab from the central pane. 

3. The application will now display the components shown in Figure 2-18. Note that the tool tip shows the maximum 
and minimum values for this property as read from the template file. 
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4. Change the value in the edit box of the Left margin from 9 to 25 and press the F5 key to refresh the view. The 
application will now display the components displayed in Figure 2-19. Note that the left arrow has moved slightly to 
the right.  

  

Figure 2-18 Horizontal Seek Bar before changing Configurable Properties 
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Figure 2-19 Horizontal Seek Bar after changing the Left Margin 

5. Change the value in the edit box of the Vertical distance from 5 to 26 and press F5. The application now displays 
the components displayed in Figure 2-20. Note that the vertical distance between the time indicator box and the 
seek bar has increased. 
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Figure 2-20 Horizontal Seek Bar after changing Vertical Distance 

The graphics that make up a component can be modified with a graphical editor; see the following section. 

2.7 Using the Graphical Editor 

The graphics that make up a component can be edited using a graphical editor, such as Microsoft Paint or Adobe 

Photoshop. To change the graphical editor used, click Tools > Set Graphical Editor. 

To edit the component graphics, perform the following steps: 
 

1. Select the Component you want to change in the tree view. The preview tip in the preview area shows the name of 
the Layout File and indicates from where this image element can be found in this Layout File. 
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Figure 2-21 Theme Studio showing a selected component 

2. Click the Edit button in the preview image’s view. The selected graphical editor is now launched and opens the 
Layout Files containing the component’s graphics.  

3. Edit the images in the graphical editor. Figure 2-22 shows a Layout File being edited in Microsoft Paint. 
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Figure 2-22 A Layout File edited in Microsoft Paint 

 

4. When all editing has been done, click File > Save. Make sure that the image is saved in the format that is specified 
as the highest priority in the Graphic File Format Priority Dialog (Figure 2-2).  

5. Now go back to Theme Studio and on the View menu, click Refresh. The preview image will now display the 
changes that were made in the graphical editor. Figure 2-23 shows the preview image after using the graphical 
editor. 
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Figure 2-23 Theme Studio showing a selected component with its image modified 

 

2.8 Image Adjustment 

The contrast and brightness of the bitmaps that are exported to the theme can be altered. Changes are also applied to 
the preview images of the components. To change the contrast or brightness for the images, perform the following 
steps: 

 

1. On the left hand tree view, expand Theme Project, then Settings, and click Image Adjustments. 

 A view, similar to the one in Figure 2-24, is displayed allowing the adjustment of the contrast and brightness 
properties. Previews of the component images are displayed in this view to show the visible effects of the 
adjustment. 
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Figure 2-24 Theme Studio showing image adjustments view 

 

2. Select the desired adjustment value by dragging either of the slider bars to the left or right. The actual value of the 
property will be updated in the edit box as the slider is moved. Note that the edit box is read-only.  

3. Once you are satisfied with the value of the adjustment property, click the Apply Image Adjustments button. The 
preview image of the component displayed below the slider bar will be redrawn with the new value. Figure 2-25 
shows a preview of a component after applying a contrast of 50 and a brightness of 50. Note that the image 

adjustment properties apply to all images included in the theme. When the Revert To Defaults button is pressed, 
the contrast and brightness values revert to the values they had when the project was first created. 

4. Select a variety of different components from the list box, in order to check the adjustments made have the desired 
effect for all images. 
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Figure 2-25 Theme Studio after adjusting contrast and brightness to 50 

Note: The contrast adjustment is applied to an image before the brightness adjustment. 

2.9 Mask & Region Colors 

Mask and Region colors are used in some images to remove the unwanted pixels when an image is shown in the UI. 

The Region color is used to specify the extent of an object, while the Mask color can be used to specify transparency. 

Before modifying a layout image file, check the mask and region colors used by Theme Studio. To do so, perform the 
following step: 

 

1. On the left hand tree view, expand Theme Project, then Settings, and click Masks. 

 A view including a color swatch for both mask and region color is displayed. The Red, Green, and Blue component 
value of each color is also shown. 
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Figure 2-26 Mask and Region Color View 

2.10 Saving a Project 

After making changes to a project an asterisk will be displayed to the right of the project’s name at the top of the tree 
view. This asterisk is an indicator that the project has been modified and has not been saved. The asterisk can be seen 
in Figure 2-17. 

To save a modified project, click File > Save. After saving, the asterisk is no longer displayed, indicating that there are 
no unsaved changes. 

2.11 Changing a Logical Font Mapping 

All of the fonts in the preview images are called logical fonts. A logical font is mapped to a system font. The system font 
that a logical font uses can be changed. To change the system font used by a logical font, perform the following steps: 

1. In the preview area of a component, moving the cursor over any text on the preview image identifies the logical font 

used for that text. For example, the logical font ECallHeaderButton is used by the Call Header Buttons 
component. 

2. On the left hand tree view, expand Theme Project, then Settings, and click Logical Fonts. 

 A view with two list boxes is displayed. The left list box shows all the logical fonts and the system font to which they 
are mapped. The list box on the right shows all of the available system fonts. 

3. Select the logical font to be changed from the left list box, for example, ECallHeaderButton. The system font that 
it maps to is then highlighted in the right list box, as shown in Figure 2-27.  
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Figure 2-27 Theme Studio with a logical font selected 

4. Select the new system font in the list box on the right. The logical font in the left list box will have been changed to 
the new system font, and the preview of the logical font will have changed accordingly. Figure 2-28 illustrates the 

change to the logical font mapping shown in Figure 2-27. Again, the Revert To Defaults button can be used to 
change any values back to their initial values set when the project was first created. 
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Figure 2-28 Theme Studio after changing the logical font mapping 

5. Check how the change to the system font affects the components that use it. Figure 2-29 shows how a change to 

the ECallHeaderButton logical font affects the Call Header Button component. 
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Figure 2-29 Call Header Buttons component after logical font change 

2.12 Changing a System Font 

There is no restriction on the number of logical fonts that may be mapped to the same system font. If a system font is 
changed then that will in turn change the appearance of all the logical fonts that map to it. To change the name, 
typeface, size, bold or italic fields of a system font perform the following steps: 

1. On the left hand pane tree view, expand Theme Project, then Settings, and click System Fonts. 

 A view with a list box will be displayed. This contains all the system fonts and a number of controls to change the 
fields of a system font.  

2. Select the system font to be changed from the list box. The preview and controls to the left of the list box will be 
updated with the details of the selected system font. Figure 2-30 shows Theme Studio with a system font selected. 
The tool tip can be seen when the cursor hovers over the typeface control. 
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Figure 2-30 Theme Studio showing the selection of a system font 

 

3. Make the desired changes to the system font. The font can be changed by altering its name, size, and also its 
typeface. Select a typeface from those displayed in the drop down list, as shown in Figure 2-31. 

4. The preview and the list box will be updated with the changes. Figure 2-32 shows the Theme Studio after making 
changes to the system font that is shown as selected in Figure 2-30. The tool tip can be seen when the cursor is 
hovering over the controls where the system font name can be changed. 
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Figure 2-31 Theme Studio showing the system font’s available typefaces 

  

Figure 2-32 Theme Studio after changing a system font 
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2.12.1 Installing a new font 

To make a new true type font (.ttf) file available to Theme Studio, perform the following steps: 

1. Copy the new font file to the clipboard. 

2. In Windows Explorer, browse to the Fonts folder of Theme Studio ’s root directory. 

3. Paste the font file into the Fonts folder. Next time the Theme Studio is launched, the new font will be available. 

System fonts that do not appear on the device or the Emulator by default will be indicated in red, as shown in Figure 
2-33. 

 

 

Figure 2-33 System Font view with newly installed fonts 

Note: Fonts are not exported when exporting a Theme to the Emulator or generating a SIS file. You should ensure that 
the fonts used are also installed on the emulator/device; otherwise an alternative font will be used. 

 
 

2.13 Changing a Logical Color 

Logical colors are used to define the colors used on the device, for example, text or background colors. To change a 
logical color, perform the following steps: 

1. In the preview area for a component, moving the cursor over any text on the preview image identifies the logical 

color used for that text. For example, the logical color EColorButtonText is used by the Call Header Buttons 
component. 
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2. On the left hand tree view, expand Theme Project, then Settings, and click Logical Colors. 

 On the left of the view, a list box of all the logical colors is displayed along with their description. On the right of the 
view are a number of controls to change the color values, and a swatch to preview the color will be displayed. 

3. Select the logical color to be changed in the list box, for example, EColorButtonText. The controls and swatch will 
be updated with the selected color’s values. 

4. Make the desired changes to the color. Changes can be made using the edit box or the color control activated by 
double-clicking on the swatch or on an item in the list, as shown in Figure 2-34. The swatch on the right hand side 
is updated when changes are made. 

 

Figure 2-34 Theme Studio changing the logical color 

5. To have changes to contrast and brightness affect a logical color, click the Apply adjustments check box. The 
color preview swatch will reflect the result of any adjustments. 

6. Check how the change to the system font affects the components that use it. Figure 2-35 shows how a change to 

the EColorButtonText logical color affects the Call Header Button component. 
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Figure 2-35 Call Header Buttons component after logical color change 

2.14 Changing a Global Property 

Global properties are global to a theme project and customizable, such as the theme’s UID and name. To change a 
global property, perform the following steps: 

 

1. On the left hand tree view, expand Theme Project, then Settings, and click Properties. See Figure 2-36. 

2. Make the desired changes. 

3. The Revert To Defaults button can be used to change all the editable properties in this view back to the values 
they had when the project was first created. 
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Figure 2-36 Global properties 

2.15 Undoing or Redoing a Change 

To undo a change or to re-implement an undone change, click either Edit > Undo or Edit > Redo respectively. Note that 
changes made to the Components via the graphical editor cannot be undone in the Theme Studio.  

 

2.16 Correcting Validation Failures 

Before the project can be exported, all validation failures (if there are any) need to be corrected. To do this, perform the 
following steps: 

1. On the left pane view, browse to the root tree item Theme Project. A view with a list of all the validation failures 
will be displayed. Figure 2-37 shows an example of this view with one validation failure. If there are no validation 
failures, the list will contain the text “(None).”  

2. To correct failures, simply make a note of the error and double-click on the failure in the list. The tool will now 
display the item that contains the validation failure (as shown in Figure 2-38), where the tool tip shows the 
maximum and minimum values for this property as determined from data in the template file. Note that the tree view 
icon also indicates an error. 
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Figure 2-37 Theme Studio showing a validation failure for a project 

 

Figure 2-38 Theme Studio showing the location of the validation failure for a project 

3. Correct the invalid value. The tool will now display one validation failure less if the root tree item is selected. 

2.17 Using the Emulator 

A theme can be exported for testing in the Emulator, before it is installed on an actual device. To export to the Emulator, 
perform the following steps: 
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1. On the left hand tree view, expand Theme Project, then Settings, and click Paths. 

 A view with an edit box for the Emulator and ROM image paths is displayed, as shown in Figure 2-39, together with 
the tool tip seen when the cursor hovers over the path control. 

 

 

Figure 2-39 Theme Studio just before setting an export path 

 

2. Set the Emulator path to the root directory of the installed Emulator package (the directory containing the epoc32 

folder), for example C:\Symbian\7.0s\Nokia_7710_SDK_CW. This can be done by either pressing the 

Browse button, which opens a browse dialog to search for the folder, or by typing the path directly into the edit 
box.  

3. On the Tools menu, point to Export to Emulator, and click Start Up Theme. If there are any validation failures in 
the project, a dialog box will open with the message “There are errors in the theme project which must be fixed 
before you can export the theme.” For more information, see Section 2.16, “Correcting Validation Failures”. If the 
export is successful, the path set in the previous step will contain the following files: 

 

a. Skinpath.txt in the folder epoc32\winscw\c\system\data\skinconfig\. This file 

determines which theme is currently loaded. 

b. <UID>.skn in the folder epoc32\winscw\c\system\skins\<UID>\. This file is the Theme 

Configuration File, where <UID> represents a placeholder for the UID string. 

c. MBM files in the folder epoc32\winscw\c\system\skins\<UID>\mbm\. These are the 

theme’s bitmap graphics, where <UID> represents a placeholder for the UID string. 

 The UID and project name can be set in the global properties (See Section 2.14, “Changing a Global Property”). 
 

4. The Emulator can now be launched for the exported files: - 
 

a. Ensure that the Emulator executable is at the following relative path: 
\epoc32\release\winscw\udeb\epoc.exe. 

b. On the Tools menu, click Launch Emulator. 

 



 

 

Forum.Nokia.com

Nokia 7710 Theme Studio for Symbian OS User’s Guide 42 

 

Figure 2-40 Emulator launched for a project before it was modified with a graphics editor 

 

Figure 2-41 Emulator launched for a project after it was modified with a graphics editor 

The startup theme of the Emulator can be changed back to its original theme by first closing the Emulator and clicking 

Tools > Revert Emulator Theme To Default. 

To export an installable theme to the Emulator, on the Tools menu, point to Export to Emulator, and click Installable 

Theme. An installable theme is one to which the user can switch by using the Themes Application utility (available via 

the Desk All>Tools>Themes menu) within the Emulator, without having to re-start the Emulator (provided the current 
theme is not the theme being exported). 
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2.18 Exporting to the Build ROM Directory 

A project can be exported and built into the ROM image. To do this, perform the following steps: 
 

1. On the left hand tree view, expand Theme Project, then Settings, and click Paths. 

 A view with an edit box for the Emulator and ROM image paths will be displayed, as shown in Figure 2-39. 

2. Set the ROM Image path to the root directory of an empty folder. This can be done by either pressing the Browse 
button, which opens a browse dialog to search for the folder, or by typing the path directly into the edit box.  

3. On the Tools menu, click Export to Device. If there are any validation failures in the project a dialog box will pop 
up with the message “There are errors in the theme project that must be fixed before you can export the theme.” 
For more information, see Section 2.16, “Correcting Validation Failures.” If successful, the path set in the previous 
step will contain the following files: 

 

a. Skinpath.txt in the folder epoc32\data\z\system\data\skinconfig\. This file 

determines which theme is currently loaded. 

b. <UID>.skn in the folder epoc32\data\z\system\skins\<UID>\. This file is the Theme 

Configuration File, where <UID> represents a placeholder for the UID string. 

c. MBM files in the folder epoc32\data\z\system\skins\<UID>\mbm\. These contain the theme 

bitmaps, where <UID> represents a placeholder for the UID string. 

d. Font files in the folder epoc32\data\z\system\fonts\. 

e. An IBY file in the folder epoc32\rom\include\. 

 

The UID and project name can be set in the global properties (See Section 2.14, “Changing a Global Property”). 
 

2.19 Creating and Installing a SIS File 

To use a theme on the Nokia 7710 smartphone, a SIS file must be created. 

To generate a SIS file, select Tools > Generate SIS File. The dialog shown in Figure 2-42 will appear asking for the 
filename and location where the SIS file is saved once it is produced. The Symbian package file (.pkg) that generates 

the SIS file is copied to the same location. 

2.19.1 Creating an unsigned SIS file 

The only information necessary to generate an unsigned SIS file is the file name of the SIS file and the location where it 
should be generated. Clicking on the associated “Browse” button displays a “Save” dialog where the user can pick a 
location and the filename to generate a SIS file based on the current skin project. Clicking the “OK” button starts SIS 
creation. Once finished the generated SIS file can then be used to install the skin on the device. 

2.19.2 Creating a signed SIS file 

Application signing is a way of adding a tamper-proof "digital signature" to a software application. It is an industry-
standard technique and is used in phones containing Symbian OS to ensure that when an application is installed in the 
phone it remains unchanged from when it was signed, proving that it has not been 'hacked' or maliciously altered. For 
Symbian Signed, a further condition of signing is that the originator's identity has been verified so that signed 
applications can be tracked back to their source. 

To generate a signed SIS file further information is required. The name and location of a private key and public 
certificate must be supplied. These are then used to sign the SIS file. Clicking on either of the associated “Browse” 
buttons displays an “Open” dialog where the user can pick the location and the filename of the desired file. Clicking the 
“OK” button starts SIS creation. 
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For further information on the Symbian Signed process, refer to their website at http://www.symbiansigned.com. 

 

Figure 2-42 Generate SIS File Dialog 

2.19.3 Loading a SIS file 

The theme can now be loaded by performing the following steps: 
 

1. Copy the SIS file onto an MMC card and insert it into the device. 

2. Switch the device on, and wait for the desktop to be displayed. 

3. Ensure that the device is sufficiently charged (no low battery warnings). 

4. Scroll down to the File Manager icon on the desktop and double-click it. 

5. Browse to the MMC card and double-click the SIS file. 

6. Select the desktop button, which is the middle icon in the top right of the screen. 

7. Using the device, on the Desk All menu, point to Tools, and click Themes. Now select the desired theme from the 
list. 

 

2.20 Adding Application Specific Graphics to a Theme 

In addition to the main theme there are application-specific graphics. 

To generate an application-specific graphics project, perform the following steps: 

1. Ensure that the theme to be extended has already been exported, (see Sections 2.17, “Using the Emulator” and 
2.18, “Exporting to the Build ROM Directory”). 

2. Create a theme as described in Section 2.3.1, “Creating a new theme project” but select the Application 

Specific Graphics Template rather than the Main Theme Template (See Figure 2-43). 

 Figure 2-44 shows the tree view of a project created from the Application Specific Graphics 

Theme Template. 
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 Figure 2-43 Theme template selection 

 

Figure 2-44 Application-specific graphics tree view 

3. On the left hand tree view, expand Theme Project, then Settings, and click Properties. 

4. Change the UID properties, where: 

a. Main Theme UID – Is the UID of the main theme to which these graphics belong. 

b. SIS UID – this is the UID for the SIS package that is produced for the application-specific graphics, so that 
they can be installed/uninstalled separately by the Application Manager on the device. This UID should be 
different to the Main Theme UID. 
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Figure 2-45 Application-specific graphics theme properties view showing UID properties 

5. Save the project. 

6. Export the theme (See Sections 2.17, “Using the Emulator” and 2.18, “Exporting to the Build ROM Directory”). 

 A series of Theme Extension (.ske) files will have been created in the main theme UID folder and corresponding 

MBM files in the MBM subfolder. 

7. Create and install the SIS file as instructed in Section 2.19, “Creating and Installing a SIS File”. 
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3 Keyboard Shortcuts 

 

Key Combination Operation 

Ctrl + n Create a new theme project 

Ctrl + o Open a theme project 

Ctrl + s Save a modified theme 

Ctrl + Shift + s Save as a copy with a new name 

Ctrl + z Undo 

Ctrl + y Redo 

Ctrl + x Cut 

Ctrl + c Copy 

Ctrl + v Paste 

F2 Launch the Emulator 

F3 Export an Installable Theme to the Emulator 

Shift + F3 Export a Start-up Theme to the Emulator 

F4 Export a Theme to the ROM Image directory 

F5 Refresh the component preview area 
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4 Terms and Abbreviations 

 

Term or abbreviation Meaning 

Emulator Software emulator of the Nokia 7710 smartphone 

IBY File ROM Image Component Include File 

Image Editor A graphics editor such as Adobe Photoshop 

Layout File A file that contains one or more images making up theme components. The format of 
the file is editor-dependant, but the simplest type of layout file will be a bitmap. 
Theme Studio generates default Layout Files when creating a new project. 

Logical Font Fonts used in theme components that are mapped to System Fonts 

Mask A color used to represent transparent image areas 

MBM Symbian OS Multi Bitmap Image  

MMC MultiMediaCard 

PC Suite Connectivity software for PC to phone 

PSD Adobe Photoshop (PSD) is the format produced by the Adobe Photoshop graphics 
editor 

Regions A color used to represent transparent image areas, but distinct from the mask color 
in that it is used to mark the outside edge of a widget 

SIS File File format that allows installation of applications onto Symbian OS phones 

Typeface The name of the typeface inside a TrueType or bitmap font file, e.g., Nokia Sans Cn 
Regular 

Theme Configuration File A file with extension *.skn that resides on the target device and contains 

information about the theme 

Theme Extension File A file with extension *.ske that resides on the phone to define themes for third 

party applications 

Theme Project File A theme configuration file for Theme Studio 

Theme Template A theme configuration used as a basis for a new theme 

UID Unique Identification number 

System Font An actual TrueType or bitmap font 

Widget A common control or dialog that is generally available for all applications and can be 
used as means of interaction 
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